Page MenuHomeMiraheze

LogicException errors when navigating Miraheze Meta
Closed, ResolvedPublic

Description

In Meta, the following internal error can be seen when navigating pages or performing actions: "Fatal exception of type "LogicException"". This error seems to appear at random (if you refresh enough times, it might let you through), and can even appear while using OAuth to login to Phabricator. I was able to trigger this when accessing Special:RecentChanges, Special:Random and Agent Isai's talkpage. I do not know if other wikis or other pages on Meta are affected, though it is very likely.

Event Timeline

OrangeStar created this task.
Herald added subscribers: Unknown Object (User), Unknown Object (User), Reception123. · View Herald TranscriptNov 10 2022, 14:28
Reception123 lowered the priority of this task from High to Normal.Nov 10 2022, 16:46

Can't reproduce so it must be an individual issue. Please try the following:

Open the private browsing mode of your web browser and login, and go to Special:UserLogout. Next, open the regular browsing mode of your web browser, delete your cookies for *.miraheze.org and try and login again

OrangeStar closed this task as Resolved.EditedNov 10 2022, 17:04
OrangeStar claimed this task.

Looks like it was solved, as I too am unable to trigger it anymore. It's not an individual issue as that is a server-side error, and the cache doesn't apply as MediaWiki tells your browser to ignore the cache when logged in. I could trigger this both logged-in and out.

Correction: I mentioned the cache because I once again didn't read people's messages fully before responding. Cookies are unlikely to be the reason, as that happened on a new browser session (my browser clears cookies on exit).

Just remembered I took a screenshot of it, I should've shared it when creating this.{F1939471}

Excelsis changed the task status from Resolved to Invalid.Nov 10 2022, 18:49
Excelsis removed OrangeStar as the assignee of this task.
Excelsis moved this task from Backlog to Short Term on the Technology-Team (MediaWiki) board.
Excelsis subscribed.

Closing as invalid as there was SRE technical intervention.

Unknown Object (User) changed the task status from Invalid to Resolved.Nov 10 2022, 18:51

It was valid and it was resolved.