Page MenuHomeMiraheze

Test all extensions for 1.39
Closed, ResolvedPublic

Description

Update this task with a list of fully tested extensions, as they are tested. Note which issues they have and whether they should be removed, are an upgrade blocker, or any other relevant details.

Only extensions or skins that seem to fully work without issue, or when the issue is acceptable to move forward with MediaWiki 1.39 deployment, should be checked off this list. Please also note blockers on the Production Blockers list of the parent task.

Note: If upstream bugs are not resolved within a reasonable time, the upgrade is prioritized over individual extensions

STATUS: ~317/317 confirmed working (100%)

Extensions:
  • 3D - not able to test; same as previous upgrades
  • AbuseFilter
  • AddHTMLMetaAndTitle
  • AdminLinks
  • AJAXPoll
  • AntiSpoof
  • ApprovedRevs
  • Arrays
  • ArticleCreationWorkflow
  • ArticlePlaceholder
  • ArticleRatings
  • ArticleToCategory2
  • AuthorProtect
  • AutoCreateCategoryPages
  • AutoCreatePage
  • Babel
  • BetaFeatures
  • BlogPage
    • Error 1146: Table 'betawiki.revision_actor_temp' doesn't exist
  • Bootstrap
  • Calendar
  • Capiunto
  • Cargo
  • CategoryExplorer
  • CategorySortHeaders
  • CategoryTree
  • CentralAuth
  • CentralNotice
  • CharInsert
  • CheckUser
  • Cite
  • CiteThisPage
  • cldr
  • CleanChanges
  • CodeEditor
  • CodeMirror
  • CollapsibleVector
  • Commentbox
  • Comments
  • CommentStreams
  • CommonsMetadata
  • ConfirmEdit
  • ContactPage
  • ContributionScores
  • CookieWarning
  • CountDownClock
  • CreatedPagesList
  • CreatePage
  • CreatePageUw
  • CreateRedirect
  • CreateWiki
  • CSS
  • DarkMode
  • DataDump - MH extension; not working anyway due to Swift
  • DataTransfer
  • DeleteUserPages
  • Description2
  • Disambiguator
  • DiscordNotifications
  • DiscussionTools
  • DismissableSiteNotice
  • DisplayTitle
  • DPLForum
  • DummyFandoomMainpageTags
  • DynamicPageList
  • DynamicPageList3
  • DynamicSidebar
  • Echo
  • Editcount
  • EditNotify
  • EditSubpages
  • EmbedSpotify
  • EmbedVideo
  • EventLogging
  • EventStreamConfig
  • ExternalData
  • FlaggedRevs
  • FlexDiagrams
  • Flow
  • FontAwesome
  • ForcePreview
  • Gadgets
  • Genealogy
  • GeoCrumbs
  • GeoData
  • GeoGebra
  • GlobalBlocking
  • GlobalCssJs
  • GlobalNewFiles
  • GlobalPreferences
  • GlobalUsage
  • GlobalUserPage
  • GlobalWatchlist
  • GoogleDocs4MW
  • GoogleNewsSitemap
  • Graph
  • GroupsSidebar
  • GrowthExperiments
  • GuidedTour
  • HAWelcome
  • HeaderTabs
  • HideSection - no options to hide?
  • HighlightLinksInCategory
  • HitCounters - broken
  • ImageMap
  • ImageRating
    • Special:ImageRating page had no activity that could be undertaken despite image files uploaded locally โ€” not 1.39 related
  • ImportDump
  • IncidentReporting
  • InputBox
  • Interwiki
  • InterwikiSorting
  • IPInfo
  • JavascriptSlideshow
  • Josa
  • JSBreadCrumbs
  • JsCalendar
  • JsonConfig
  • Kartographer
  • LabeledSectionTransclusion
  • LanguageSelector
  • LastModified
  • LdapAuthentication (worked with proxy)
  • Lingo
  • LinkSuggest
  • LinkTarget
  • LinkTitles
  • Linter
  • Listings
  • LockAuthor
  • LoginNotify
  • LogoFunctions
  • Loops
  • MagicNoCache
  • ManageWiki
    • Exception on Special:ManageWiki/namespaces
  • Maps
  • MassEditRegex
  • MassMessage
  • Math
  • MatomoAnalytics
  • MediaWikiChat
  • Mermaid
  • MintyDocs
  • MirahezeMagic
  • MixedNamespaceSearchSuggestions
  • MobileDetect
  • MobileFrontend
  • MobileTabsPlugin
  • Moderation
  • MsCalendar
  • MsCatSelect
  • MsLinks
  • MsUpload -- unsure if error encountered below is intended behavior, if so, this is safe to close as working, multiple file types in various combinations uploaded successfully.
    • Valid images files fail to upload if improper files were included in the same batch
  • MultiBoilerplate
  • MultimediaViewer
  • MyVariables
  • NamespacePreload
  • NativeSvgHandler
  • NewestPages
  • NewSignupPage
  • Newsletter
  • NewUserMessage
  • NewUserNotif
  • NoTitle
  • Nuke
  • NukeDPL
  • OATHAuth
  • OAuth
  • OpenGraphMeta
  • OrphanedTalkPages
  • PageAssessments
  • PagedTiffHandler
  • PageForms
  • PageImages
  • PageNotice
  • PageProperties
  • PageSchemas
  • PageTriage
  • ParserFunctions
  • PdfBook (will be removed)
    • [5f26ec1f0f62b2bc17a2e8a0] 2022-10-29 09:51:27: Fatal exception of type "Error"
  • PDFEmbed
    • Received error when tagging - Unauthorized This server could not verify that you are authorized to access the document you requested. โ€” not 1.39 related
  • PdfHandler
  • PipeEscape
  • Poem
  • PollNY
  • Popups
  • PortableInfobox
  • Preloader
  • ProofreadPage
  • PropertySuggester
  • ProtectionIndicator
  • ProtectSite
  • Purge
  • QuickInstantCommons
  • Quiz
  • QuizGame
  • RandomGameUnit
  • RandomImage
  • RandomSelection
  • RatePage
  • RegexFunctions
  • RelatedArticles
  • RemovePII
  • Renameuser
  • ReplaceText
  • Report
  • RevisionSlider
  • RightFunctions
  • RottenLinks
  • RSS
  • SandboxLink
  • Score
  • ScratchBlocks4
  • Scribunto
  • SecureLinkFixer
  • SemanticFormsSelect
  • SemanticMediaWiki
  • Share
  • ShortDescription
  • SimpleBlogPage
  • SimpleChanges
  • SimpleTooltip
    • All tooltips appear to work aside from Inline-Image, multiple attempts at alternate syntax were unsuccessful. (root cause was undocumented expectation of full URL path)
  • SkinPerPage
  • SlackNotifications (will be removed)
    • /srv/mediawiki/w/extensions/SlackNotifications/SlackNotificationsCore.php:328 Call to undefined method MediaWiki\Block\DatabaseBlock::getTarget()
  • SnapProjectEmbed
  • SocialProfile
  • SoftRedirector
  • SpamBlacklist
  • Spoilers
  • SpriteSheet
  • StandardDialogs
  • StopForumSpam (not really possible to test; assuming works)
  • StructuredNavigation
  • SubpageFun
  • SubPageList3
  • SyntaxHighlight_GeSHi
  • TabberNeue
  • Tabs
  • TemplateData
  • TemplateSandbox
  • TemplateStyles
  • TemplateStylesExtender
  • TemplateWizard
  • TextExtracts
  • Thanks
  • Theme
  • TimedMediaHandler
  • Timeline
  • TimeMachine
  • TitleBlacklist
  • TitleKey
  • TocTree
  • TorBlock
  • Translate
  • TranslationNotifications
  • TreeAndMenu
  • TwitterTag
  • TwoColConflict
  • UniversalLanguageSelector
  • UploadsLink
  • UploadWizard
  • UrlGetParameters
  • UrlShortener
  • UserFunctions
  • UserPageEditProtection
  • Variables
  • VariablesLua
  • VEForAll
  • Video
  • VisualEditor
  • VoteNY
  • WebChat
  • Wikibase
  • WikibaseEdtf
  • WikibaseLexeme
  • WikibaseLocalMedia
  • WikibaseQualityConstraints
  • WikiCategoryTagCloud
  • WikidataPageBanner
  • WikiDiscover
  • WikiEditor
  • WikiForum - disabled anyway; not applicable
  • wikihiero
  • WikiLove - Cannot send to self, but that matches current behavior in live.
  • WikimediaIncubator
  • WikiSEO
  • WikiTextLoggedInOut
  • YouTube
Skins:
  • Anisa
  • apex
  • BlueSky
  • chameleon
  • Citizen
  • CologneBlue
  • Cosmos
  • DuskToDawn
  • erudite
  • Evelution
  • Femiwiki
  • Flatbox
  • Gamepress
  • HasSomeColours
  • Mask
  • Medik
  • Metrolook
  • MinervaNeue
  • Mirage
  • Modern
  • Monaco
  • MonoBook
  • Nimbus
  • Nostalgia
  • Refreshed
  • Snap!
  • Timeless
  • Truglass
  • Tweeki
  • Vector
  • WMAU

Related Objects

StatusAssignedTask
ResolvedUnknown Object (User)
ResolvedUnknown Object (User)

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Unknown Object (User) updated the task description. (Show Details)Sep 12 2022, 22:05
Unknown Object (User) updated the task description. (Show Details)Sep 12 2022, 22:08
Unknown Object (User) updated the task description. (Show Details)Sep 13 2022, 20:11
NotAracham updated the task description. (Show Details)
NotAracham updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Oct 25 2022, 18:27

I think the Wikibase extension needs to be enabled on betawiki to test it out.

Unknown Object (User) added a comment.Oct 25 2022, 23:10
In T9745#199241, @Ugochimobi wrote:

I think the Wikibase extension needs to be enabled on betawiki to test it out.

There is an issue with Wikibase and ManageWiki compatibility on betawiki right now that I will look into later.

MacFan4000 updated the task description. (Show Details)
Excelsis updated the task description. (Show Details)
Excelsis updated the task description. (Show Details)
  • AutoCreatePage - doesn't seem to work/unmaintained since 2017

From this contributor's site, recent evidence to the contrary.

MacFan4000 raised the priority of this task from Low to High.Dec 1 2022, 14:59

Wikibase returns Could not save due to an error. [8a3b90e8eb3703286c55dfc2] Caught exception of type MWException when trying to save a Mathematical expression statement.
You can also reproduce by testing it on this Test item (https://beta.betaheze.org/wiki/Item:Q4), add statement with property "math test property" and add the value as a^2 + b^2 = c^2, then save.

In T9745#202938, @Ugochimobi wrote:

Wikibase returns Could not save due to an error. [8a3b90e8eb3703286c55dfc2] Caught exception of type MWException when trying to save a Mathematical expression statement.
You can also reproduce by testing it on this Test item (https://beta.betaheze.org/wiki/Item:Q4), add statement with property "math test property" and add the value as a^2 + b^2 = c^2, then save.

Seems to be Mathoid related, not Wikibase:

Mathoid check returned unexpected error code.
from /srv/mediawiki/w/extensions/Math/src/InputCheck/MathoidChecker.php(103)
#0 /srv/mediawiki/w/includes/libs/objectcache/wancache/WANObjectCache.php(1689): MediaWiki\Extension\Math\InputCheck\MathoidChecker->runCheck(boolean, integer, array, NULL, array)
#1 /srv/mediawiki/w/includes/libs/objectcache/wancache/WANObjectCache.php(1522): WANObjectCache->fetchOrRegenerate(string, integer, array, array, array)
#2 /srv/mediawiki/w/extensions/Math/src/InputCheck/MathoidChecker.php(68): WANObjectCache->getWithSetCallback(string, integer, array, array)
#3 /srv/mediawiki/w/extensions/Math/src/InputCheck/MathoidChecker.php(117): MediaWiki\Extension\Math\InputCheck\MathoidChecker->getCheckResponse()
#4 /srv/mediawiki/w/extensions/Math/src/MathValidator.php(38): MediaWiki\Extension\Math\InputCheck\MathoidChecker->isValid()
#5 /srv/mediawiki/w/extensions/Wikibase/repo/includes/Validators/SnakValidator.php(209): MediaWiki\Extension\Math\MathValidator->validate(DataValues\StringValue)
#6 /srv/mediawiki/w/extensions/Wikibase/repo/includes/Validators/SnakValidator.php(150): Wikibase\Repo\Validators\SnakValidator->validateDataValue(DataValues\StringValue, string)
#7 /srv/mediawiki/w/extensions/Wikibase/repo/includes/Validators/SnakValidator.php(58): Wikibase\Repo\Validators\SnakValidator->validate(Wikibase\DataModel\Snak\PropertyValueSnak)
#8 /srv/mediawiki/w/extensions/Wikibase/repo/includes/ChangeOp/ChangeOpStatement.php(227): Wikibase\Repo\Validators\SnakValidator->validateStatementSnaks(Wikibase\DataModel\Statement\Statement)
#9 /srv/mediawiki/w/extensions/Wikibase/repo/includes/Api/StatementModificationHelper.php(172): Wikibase\Repo\ChangeOp\ChangeOpStatement->validate(Wikibase\DataModel\Entity\Item)
#10 /srv/mediawiki/w/extensions/Wikibase/repo/includes/Api/SetClaim.php(207): Wikibase\Repo\Api\StatementModificationHelper->applyChangeOp(Wikibase\Repo\ChangeOp\ChangeOpStatement, Wikibase\DataModel\Entity\Item, Wikibase\Lib\Summary)
#11 /srv/mediawiki/w/extensions/Wikibase/repo/includes/Api/SetClaim.php(163): Wikibase\Repo\Api\SetClaim->executeInternal()
#12 /srv/mediawiki/w/includes/api/ApiMain.php(1900): Wikibase\Repo\Api\SetClaim->execute()
#13 /srv/mediawiki/w/includes/api/ApiMain.php(875): ApiMain->executeAction()
#14 /srv/mediawiki/w/includes/api/ApiMain.php(846): ApiMain->executeActionWithErrorHandling()
#15 /srv/mediawiki/w/api.php(90): ApiMain->execute()
#16 /srv/mediawiki/w/api.php(45): wfApiMain()
#17 {main}

It can be resolved?
Well, because it affects wikibase at this point.

Unknown Object (User) added a comment.Dec 5 2022, 21:10
In T9745#202949, @Ugochimobi wrote:

It can be resolved?
Well, because it affects wikibase at this point.

Mathoid check endpoint "https://mathoid-beta.wmflabs.org/texvcinfo" returned HTTP status code "404" for post data

Is the actual error here, it is because https://mathoid-beta.wmflabs.org/texvcinfo does not exist.

ArticlePlaceholder returns [ea174b74c25e329e12d7729d] 2022-12-06 10:16:54: Fatal exception of type "Wikibase\DataModel\Services\Lookup\EntityLookupException" when trying to do what it needs to do. Visit here https://beta.betaheze.org/wiki/Special:AboutTopic/Item:Q57 for reproduction.

MacFan4000 subscribed.

Unchecked ManageWiki as i noticed an exception when going to Namespace settings.

Unknown Object (User) added a comment.Dec 21 2022, 17:45

Unchecked ManageWiki as i noticed an exception when going to Namespace settings.

Unrelated to 1.39, and I already fixed it, just hasn't been updated on 1.39 yet.

  • SimpleTooltip
    • All tooltips appear to work aside from Inline-Image, multiple attempts at alternate syntax were unsuccessful. (root cause was undocumented expectation of full URL path)

Not to mention this unresolved upstream issue from December 2020 re: poor support for lists. Keep in mind original developer Simon "Fannon" Heimler hasn't been on Wikimedia since 2017, as I noted in an earlier FTA of mine. Anything you can do about it, UO?

Unknown Object (User) added a comment.Dec 22 2022, 18:40
  • SimpleTooltip
    • All tooltips appear to work aside from Inline-Image, multiple attempts at alternate syntax were unsuccessful. (root cause was undocumented expectation of full URL path)

Not to mention this unresolved upstream issue from December 2020 re: poor support for lists. Keep in mind original developer Simon "Fannon" Heimler hasn't been on Wikimedia since 2017, as I noted in an earlier FTA of mine. Anything you can do about it, UO?

I maintain a new version of SimpleTooltip now, so yeah, I can take a look later.

I noticed that a pre-release version of MediaWiki 1.40 has been released recently. Will there be a situation where we, Miraheze, will catch the official 1.40 release just when we are ready to upgrade to 1.39? This may be quite dramatic, but given the current pace of testing (T9745), I think it is possible. :P

Unknown Object (User) added a comment.Dec 23 2022, 02:08

I noticed that a pre-release version of MediaWiki 1.40 has been released recently. Will there be a situation where we, Miraheze, will catch the official 1.40 release just when we are ready to upgrade to 1.39? This may be quite dramatic, but given the current pace of testing (T9745), I think it is possible. :P

We plan to upgrade to 1.39 in January. 1.40 isn't going to be released until May.

Unknown Object (User) updated the task description. (Show Details)Dec 23 2022, 19:01
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Dec 23 2022, 19:13
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Jan 7 2023, 19:58
Unknown Object (User) updated the task description. (Show Details)Jan 7 2023, 20:00
Unknown Object (User) updated the task description. (Show Details)Jan 8 2023, 00:08
Unknown Object (User) updated the task description. (Show Details)Jan 9 2023, 17:30

Due to large delay that already exists in upgrading, I would recommend that unless extensions are important/essential if they don't work we still proceed on the 21st

Unknown Object (User) updated the task description. (Show Details)Jan 11 2023, 17:54
Unknown Object (User) updated the task description. (Show Details)Jan 11 2023, 18:32
Unknown Object (User) updated the task description. (Show Details)Jan 11 2023, 19:14
Unknown Object (User) closed this task as Resolved.Jan 15 2023, 02:14
Unknown Object (User) claimed this task.
Unknown Object (User) updated the task description. (Show Details)