Page MenuHomeMiraheze

MediaWiki internal error while logged in
Closed, ResolvedPublic

Description

What is this 🙄 ?

MediaWiki internal error.

Original exception: [9560e5e11d21c9bb69a35ad1] 2022-04-12 07:03:43: Fatal exception of type "Error"

Exception caught inside exception handler.

Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information.

Event Timeline

Herald added subscribers: Unknown Object (User), Unknown Object (User), RhinosF1, Reception123. · View Herald TranscriptApr 12 2022, 07:04

Hello,

Can anyone having this issue please state on what wiki?

I have the issue on my private wiki: Lenawiki

https://lenawiki.miraheze.org/

'

MediaWiki internal error.

Original exception: [9560e5e11d21c9bb69a35ad1] 2022-04-12 07:03:43: Fatal exception of type "Error"

Exception caught inside exception handler.

Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information.

'

The site is not opening.

In T9064#183594, @M.22 wrote:

I have the issue on my private wiki: Lenawiki

https://lenawiki.miraheze.org/

Thank you. I can reproduce on your wiki. Now just to find someone online who can fix.

Below is the full exception

Call to a member function getCanonicalServer() on null
from /srv/mediawiki/w/extensions/CentralAuth/includes/CentralAuthHooks.php(1128)
#0 /srv/mediawiki/w/includes/HookContainer/HookContainer.php(160): CentralAuthHooks->onBeforePageDisplay(OutputPage, SkinMinerva)
#1 /srv/mediawiki/w/includes/HookContainer/HookRunner.php(947): MediaWiki\HookContainer\HookContainer->run(string, array, array)
#2 /srv/mediawiki/w/includes/OutputPage.php(2639): MediaWiki\HookContainer\HookRunner->onBeforePageDisplay(OutputPage, SkinMinerva)
#3 /srv/mediawiki/w/includes/MediaWiki.php(944): OutputPage->output(boolean)
#4 /srv/mediawiki/w/includes/MediaWiki.php(957): MediaWiki::{closure}()
#5 /srv/mediawiki/w/includes/MediaWiki.php(564): MediaWiki->main()
#6 /srv/mediawiki/w/index.php(53): MediaWiki->run()
#7 /srv/mediawiki/w/index.php(46): wfIndexMain()
#8 {main}

When will this problem be solved?

When will this problem be solved?

You have to be very patient with the system administrators, so when they figure out what's wrong, then a fix would also be done.

I apologise for the inconvenience this error is causing. Unfortunately this has not yet been resolved because no volunteers have had access to our servers to have a look (likely due to real life commitments).

@Paladox do you think you could look?

Reception123 renamed this task from MediaWiki internal error. to MediaWiki internal error while logged in .Apr 12 2022, 15:42
MacFan4000 assigned this task to Unknown Object (User).Apr 12 2022, 16:26
Unknown Object (User) closed this task as Resolved.Apr 12 2022, 18:00
Unknown Object (User) edited projects, added Configuration, Production Error; removed MediaWiki.
Unknown Object (User) moved this task from Backlog to Short Term on the Technology-Team (MediaWiki) board.

I apologise for the issue. It has now been fixed.