Page MenuHomeMiraheze

Involuntary change from mobile version to desktop version when changing pages
Closed, ResolvedPublic

Description

I couldn't find a task for this here in Phabricator, so first I apologize if this is duplicated from another task in progress. But lately this action has been bothering me a lot especially in mobile browsing. It is noticed that this happens only in the wiki(s) of Miraheze, that, as much as without or with MobileFrontend and in all themes including the MinervaNeue pattern, something happens in the navigation that makes you go to the desktop theme without the your permission, getting in the way a lot. Noting that this happens especially when trying to research something. I've never seen anyone quoting it, despite it being 'exclusive' to Miraheze. A remedy to this would be perfect for the satisfaction of visitors. Let's take an example from the wiki currently managed by me, which, when switching pages to a heavy one, the mobile theme changes itself to the desktop, as stated above.

Event Timeline

YellowFrogger triaged this task as Normal priority.Jan 8 2022, 22:03
YellowFrogger created this task.
Unknown Object (User) added a comment.Jan 8 2022, 22:05

Can you please give an example of this happening, as I'm unable to reproduce?

This sounds like a cookie issue to me

Unknown Object (User) added a comment.Jan 8 2022, 22:09

This sounds like a cookie issue to me

Yes that was my first thoughts as well. It could be an issue with your browser @YellowFrogger.

I assure you that it is not any browser error or cookies or anything related. The explanation for this is difficult because I've already tested it with other MediaWiki wikis, but this only happens on Miraheze-hosted wikis. You can analyze it yourself. It would be great if some system wizard here, look for something that causes this, or even solve it. I've already done a test in two browsers, and the same happens with other devices.

Unknown Object (User) added a comment.Jan 8 2022, 22:21

Can you provide exact reproduction steps, such as pages visited in between the switch, and the exact actions you took?

@Universal_Omega Please do it yourself. On mobile, when doing a search, the theme automatically switches to the desktop theme abruptly and unintentionally. This doesn't happen on small pages, it happens on large pages or in wiki search.

Unknown Object (User) added a comment.Jan 8 2022, 22:26

It doesn't for me.

I don't believe this happens just for me. I invite the automatic subscribers of this task to do the same (On cell phone (or mobile) click on that gray magnifying glass, and do a search even without characters). Theme will stay desktop. I guarantee. I just need to make a video showing this, to prove it.

Partial repro. Visiting a wiki using some sort of mobile responsive features loads fine. Skin remains mobile throughout search (from tapping search icon to entering search terms). Site displays desktop for results. This may be intended behavior, though, as it uses Special:Search. Clicking results returns to mobile version.

Firefox for Android 95.0.14, Android 9, Samsung Galaxy S8

Unknown Object (User) added a comment.Jan 9 2022, 08:42

Search results on Special:Search being desktop I think is intentional behaviour. Thanks for the info.

If it's intentional, something probably causes it. To extend the above stub, this also happens when we go to very heavy pages, and especially when we are logged in, annoying.

@Universal_Omega , could you help this, to see the function causing this, because I think it's public utility, this can be good or bad (bad for me). Or elevate that to an RfC to see community votes?

If it's intentional, something probably causes it.

Intended behavior indicates that it is working properly when that happens. If search results displaying in desktop mode is determined to be intended behavior, that means everything is working properly when search changes to desktop mode. If this is the case, there is nothing wrong with the function of the features, and therefore nothing to fix.

Unknown Object (User) added a comment.Jan 10 2022, 06:39

An RfC is not appropriate since there is nothing we can do even if it passed. I'm almost certain this is intended behavior.

You need to find out more about it here (it doesn't just happen when you go researching something). If it is intentional, I object so, per my reasons cited here. This for me, hinders more than helps. First, the theme is no longer responsive.

So, if it's intentional, how do I make a request to remove them?

Unknown Object (User) added a comment.Jan 10 2022, 21:00

We are not able to change intentional functionality.

Unknown Object (User) added a comment.EditedJan 10 2022, 21:02

Although I just tried this myself again, and I still don't understand the issue, when using the mobile version (through MobileFrontend/MinervaNeue) Special:Search is in mobile version.

I’ve actually experienced this a lot, but it seems to be the way it works, either with cookies, or analyzing the screen resolution, and based on that, using the set mobile skin. If it is the latter (which I believe it is), it would not be changeable, as it is the intended functionality (afaik).

Unknown Object (User) added a comment.Jan 13 2022, 01:43

OK, I looked into this a bit:

This does seem to be somewhat of a valid issue, however I'm not sure what we can really do about it. It is some sort of issue with cookies not being set for anonymous users correctly or something similar it would seem.

@Bukkit this has probably already shown that it's not cookies error, it happens with clean browsers. And, @Universal_Omega this doesn't just happen with Minerva, it happens with Timeless, among other mobile themes. 2: Happens to logged in users as well 3: heavy pages usually take a while to load and in the end, "fall over" with it (desktop theme being shown). This is a readability issue.

@Bukkit Also, it doesn't happen with WMF wikis and any other type of wiki that uses MediaWiki software. Only Miraheze.

Unknown Object (User) closed this task as Resolved.Jan 13 2022, 17:36
Unknown Object (User) claimed this task.
Unknown Object (User) moved this task from Backlog to Short Term on the MediaWiki (SRE) board.
Unknown Object (User) moved this task from Unsorted to Short Term on the Universal Omega board.
Unknown Object (User) edited projects, added Puppet; removed Extensions.

I am no longer able to reproduce this myself as I could before as mentioned above. So going to go ahead and close this task as resolved.

I wish it was resolved.
I've been experiencing this a lot lately.

MinervaNeue mobile, anonymous, Miraheze only.
It seems to be random.

Yea, @Ora. But this really seems to have been resolved (partially because some pages still do this, I think the same thing happens (useformat=mobile). Does it still happen to you?

Unknown Object (User) removed subscribers: Bukkit, Unknown Object (User).Feb 11 2022, 09:03

I confirmed it was fixed, the previous way I replicated it I was no longer able to. It doesn't happen to me at all anymore, and if it does it might be an issue with your browser or something else.

Two devices, different browsers.