Page MenuHomeMiraheze

Fatal exception of type "Error" when click the "save" or "show preview" button.
Closed, InvalidPublic

Description

Reproduction:

  1. Open the following URL: https://minecraftjapan.miraheze.org/w/index.php?title=MediaWiki:ItemSprite.json&action=edit
  2. Push the "Save" or "Show Preview" button. (Note: This is a MediaWiki namespace, so you may need administrator permission.)
  3. Then you will see:

[56f93b0c3e6be9befb1b410b] 2021-12-12 10:24:07: Fatal exception of type "Error"

.

Event Timeline

Herald added subscribers: Unknown Object (User), Unknown Object (User), RhinosF1, Reception123. · View Herald TranscriptDec 12 2021, 10:32
Unknown Object (User) added a comment.Dec 12 2021, 21:48

The issue is with the Lingo extension. https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Lingo/+/745880 should fix it if merged upstream.

Call to a member function getText() on null
from /srv/mediawiki/w/extensions/Lingo/src/LingoParser.php(191)
#0 /srv/mediawiki/w/extensions/Lingo/src/LingoParser.php(80): Lingo\LingoParser->realParse(Parser)
#1 /srv/mediawiki/w/extensions/Lingo/src/Lingo.php(61): Lingo\LingoParser->parse(Parser)
#2 /srv/mediawiki/w/includes/HookContainer/HookContainer.php(338): Lingo\Lingo::Lingo\{closure}(JsonContent, Title, ParserOutput)
#3 /srv/mediawiki/w/includes/HookContainer/HookContainer.php(137): MediaWiki\HookContainer\HookContainer->callLegacyHook(string, array, array, array)
#4 /srv/mediawiki/w/includes/HookContainer/HookRunner.php(1212): MediaWiki\HookContainer\HookContainer->run(string, array)
#5 /srv/mediawiki/w/includes/content/AbstractContent.php(552): MediaWiki\HookContainer\HookRunner->onContentAlterParserOutput(JsonContent, Title, ParserOutput)
#6 /srv/mediawiki/w/includes/EditPage.php(4212): AbstractContent->getParserOutput(Title, NULL, ParserOptions)
#7 /srv/mediawiki/w/includes/EditPage.php(4115): EditPage->doPreviewParse(JsonContent)
#8 /srv/mediawiki/w/includes/EditPage.php(2893): EditPage->getPreviewText()
#9 /srv/mediawiki/w/includes/EditPage.php(722): EditPage->showEditForm()
#10 /srv/mediawiki/w/includes/actions/EditAction.php(71): EditPage->edit()
#11 /srv/mediawiki/w/includes/actions/SubmitAction.php(38): EditAction->show()
#12 /srv/mediawiki/w/includes/MediaWiki.php(538): SubmitAction->show()
#13 /srv/mediawiki/w/includes/MediaWiki.php(320): MediaWiki->performAction(Article, Title)
#14 /srv/mediawiki/w/includes/MediaWiki.php(925): MediaWiki->performRequest()
#15 /srv/mediawiki/w/includes/MediaWiki.php(559): MediaWiki->main()
#16 /srv/mediawiki/w/index.php(53): MediaWiki->run()
#17 /srv/mediawiki/w/index.php(46): wfIndexMain()
#18 {main}
Unknown Object (User) triaged this task as Normal priority.Dec 12 2021, 21:48
Unknown Object (User) added projects: Extensions, Technology-Team (MediaWiki).
Unknown Object (User) moved this task from Backlog to Deployed Extension Bugs on the Extensions board.Dec 12 2021, 21:48
Unknown Object (User) moved this task from Backlog to Short Term on the Technology-Team (MediaWiki) board.
Unknown Object (User) moved this task from Unsorted to Short Term on the Universal Omega board.
Unknown Object (User) closed this task as Invalid.Dec 12 2021, 23:37
Unknown Object (User) claimed this task.
Unknown Object (User) added a project: Upstream.

Closing as invalid since nothing more can be done on our side now, and it is up to upstream to merge my patch. To resolve the issue for you, you will need to disable Lingo it would seem.

We've solved it. Thank you very much for investigating the cause of this problem.