Page MenuHomeMiraheze

Error after upgrading miraheze to 1.37.0
Closed, ResolvedPublic

Description

When I open some pages, a fatal exception is shown instead of their expected contents.

For example, opening https://matesveler.miraheze.org/wiki/Especial:RunQuery/Llista_zk_per_tag

then this missage is displayed.

[b14dc2594ab7e42dfba33a34] 2021-12-07 19:15:06: Excepció fatal del tipus «Wikimedia\Rdbms\DBQueryError»

but not the expected contents.

Could you solve it? It's very important, because I use it as a personal task scheduler, with Cargo extension and Page Forms.

Thank you!

Event Timeline

Note to sysadmins:

Error 1054: Unknown column 'anotacions_zk._pageID' in 'field list' (db11.miraheze.org)
Function: CargoSQLQuery::run
Query: SELECT  `anotacions_zk`.`_pageID` AS `cargo_backlink_page_id_anotacions_zk`,`_value` AS `_value`  FROM `cargo__anotacions_zk__tags`     GROUP BY `_value` ORDER BY `_value` LIMIT 100
from /srv/mediawiki/w/includes/libs/rdbms/database/Database.php(1809)
#0 /srv/mediawiki/w/includes/libs/rdbms/database/Database.php(1793): Wikimedia\Rdbms\Database->getQueryException(string, integer, string, string)
#1 /srv/mediawiki/w/includes/libs/rdbms/database/Database.php(1768): Wikimedia\Rdbms\Database->getQueryExceptionAndLog(string, integer, string, string)
#2 /srv/mediawiki/w/includes/libs/rdbms/database/Database.php(1327): Wikimedia\Rdbms\Database->reportQueryError(string, integer, string, string, boolean)
#3 /srv/mediawiki/w/includes/libs/rdbms/database/Database.php(2012): Wikimedia\Rdbms\Database->query(string, string, integer)
#4 /srv/mediawiki/w/extensions/Cargo/includes/CargoSQLQuery.php(1562): Wikimedia\Rdbms\Database->select(array, array, string, string, array, NULL)
#5 /srv/mediawiki/w/extensions/Cargo/includes/parserfunctions/CargoQuery.php(102): CargoSQLQuery->run()
#6 /srv/mediawiki/w/includes/parser/Parser.php(3407): CargoQuery::run(Parser, string, string, string, string, string)
#7 /srv/mediawiki/w/includes/parser/Parser.php(3092): Parser->callParserFunction(PPTemplateFrame_Hash, string, array)
#8 /srv/mediawiki/w/includes/parser/PPFrame_Hash.php(273): Parser->braceSubstitution(array, PPTemplateFrame_Hash)
#9 /srv/mediawiki/w/includes/parser/PPTemplateFrame_Hash.php(97): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
#10 /srv/mediawiki/w/includes/parser/Parser.php(3278): PPTemplateFrame_Hash->cachedExpand(string, PPNode_Hash_Tree)
#11 /srv/mediawiki/w/includes/parser/PPFrame_Hash.php(273): Parser->braceSubstitution(array, PPFrame_Hash)
#12 /srv/mediawiki/w/includes/parser/Parser.php(3006): PPFrame_Hash->expand(PPNode_Hash_Tree)
#13 /srv/mediawiki/w/includes/parser/PPFrame_Hash.php(273): Parser->braceSubstitution(array, PPFrame_Hash)
#14 /srv/mediawiki/w/includes/parser/Parser.php(2930): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
#15 /srv/mediawiki/w/includes/parser/Parser.php(1598): Parser->replaceVariables(string)
#16 /srv/mediawiki/w/includes/parser/Parser.php(656): Parser->internalParse(string)
#17 /srv/mediawiki/w/extensions/PageForms/includes/PF_FormUtils.php(506): Parser->parse(string, Title, ParserOptions, boolean, boolean)
#18 /srv/mediawiki/w/extensions/PageForms/includes/PF_FormPrinter.php(958): PFFormUtils::getFormDefinition(Parser, string, integer)
#19 /srv/mediawiki/w/includes/StubObject.php(120): PFFormPrinter->formHTML(string, boolean, boolean, integer, NULL, NULL, NULL, boolean, boolean, boolean, array, User)
#20 /srv/mediawiki/w/includes/StubObject.php(149): StubObject->_call(string, array)
#21 /srv/mediawiki/w/extensions/PageForms/specials/PF_RunQuery.php(89): StubObject->__call(string, array)
#22 /srv/mediawiki/w/extensions/PageForms/specials/PF_RunQuery.php(28): PFRunQuery->printPage(string, boolean)
#23 /srv/mediawiki/w/includes/specialpage/SpecialPage.php(647): PFRunQuery->execute(string)
#24 /srv/mediawiki/w/includes/specialpage/SpecialPageFactory.php(1366): SpecialPage->run(string)
#25 /srv/mediawiki/w/includes/MediaWiki.php(314): MediaWiki\SpecialPage\SpecialPageFactory->executePath(string, RequestContext)
#26 /srv/mediawiki/w/includes/MediaWiki.php(925): MediaWiki->performRequest()
#27 /srv/mediawiki/w/includes/MediaWiki.php(559): MediaWiki->main()
#28 /srv/mediawiki/w/index.php(53): MediaWiki->run()
#29 /srv/mediawiki/w/index.php(46): wfIndexMain()
#30 {main}

@TylerMagee Please leave tasks as they are.

Reception123 raised the priority of this task from High to Unbreak Now!.Dec 7 2021, 19:55

All The Tropes is also receiving a similar error on any attempt to edit or create a page:

[fce5dff298319b556427e025] 2021-12-07 20:02:19: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

WikiHood is having the same thing.

Original exception: [604865d62755142bcf518405] 2021-12-07 20:09:53: Fatal exception of type "ParseError"

Poser and Daz Free Resources is having the same problem with editing, and with displaying the Moderation list.

and of course famedatawiki, gratisdatawiki, famepediawiki and gratispaideiawiki experiences same issue, unable to view some special pages, unable to create new pages, unable to save edits.

At this writing, new templates cannot be created on my site ("Fatal exception of type 'Error'"), while all other namespaces have no issues as such.

Unknown Object (User) added a comment.Dec 8 2021, 00:55

Cargo issue should now be fixed

Unknown Object (User) added a comment.Dec 8 2021, 00:56

All The Tropes is also receiving a similar error on any attempt to edit or create a page:

[fce5dff298319b556427e025] 2021-12-07 20:02:19: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

that should be fixed

Unknown Object (User) added a subscriber: Mb1209.Dec 8 2021, 00:56

WikiHood is having the same thing.

Original exception: [604865d62755142bcf518405] 2021-12-07 20:09:53: Fatal exception of type "ParseError"

Should be fixed

Unknown Object (User) added a comment.Dec 8 2021, 00:56
In T8396#169704, @Ugochimobi wrote:

and of course famedatawiki, gratisdatawiki, famepediawiki and gratispaideiawiki experiences same issue, unable to view some special pages, unable to create new pages, unable to save edits.

Should be fixed

Unknown Object (User) added a comment.Dec 8 2021, 00:57

At this writing, new templates cannot be created on my site ("Fatal exception of type 'Error'"), while all other namespaces have no issues as such.

Can you please provide the exception ID? It is the random hash within the brackets.

Can you please provide the exception ID? It is the random hash within the brackets.

[9c06ede8f4569d10d2a7fca8] 2021-12-08 01:00:43.

Unknown Object (User) added a comment.Dec 8 2021, 01:18
Class 'Revision' not found
from /srv/mediawiki/w/extensions/Preloader/Preloader.class.php(42)
#0 /srv/mediawiki/w/extensions/Preloader/Preloader.class.php(9): Preloader::sourceText(string)
#1 /srv/mediawiki/w/includes/HookContainer/HookContainer.php(338): Preloader::mainHook(string, Title)
#2 /srv/mediawiki/w/includes/HookContainer/HookContainer.php(137): MediaWiki\HookContainer\HookContainer->callLegacyHook(string, array, array, array)
#3 /srv/mediawiki/w/includes/HookContainer/HookRunner.php(1499): MediaWiki\HookContainer\HookContainer->run(string, array)
#4 /srv/mediawiki/w/includes/EditPage.php(679): MediaWiki\HookContainer\HookRunner->onEditFormPreloadText(string, Title)
#5 /srv/mediawiki/w/includes/actions/EditAction.php(71): EditPage->edit()
#6 /srv/mediawiki/w/includes/MediaWiki.php(538): EditAction->show()
#7 /srv/mediawiki/w/includes/MediaWiki.php(320): MediaWiki->performAction(Article, Title)
#8 /srv/mediawiki/w/includes/MediaWiki.php(925): MediaWiki->performRequest()
#9 /srv/mediawiki/w/includes/MediaWiki.php(559): MediaWiki->main()
#10 /srv/mediawiki/w/index.php(53): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(46): wfIndexMain()
#12 {main}
Unknown Object (User) added a comment.Dec 8 2021, 01:59

I have forked Preloader since it was unmaintained - https://github.com/Universal-Omega/Preloader/pull/1 should fix that once we switch to my fork.

Unknown Object (User) added a comment.Dec 8 2021, 02:09

Poser and Daz Free Resources is having the same problem with editing, and with displaying the Moderation list.

Should be fixed

Unknown Object (User) added a comment.Dec 8 2021, 02:39

At this writing, new templates cannot be created on my site ("Fatal exception of type 'Error'"), while all other namespaces have no issues as such.

Should be fixed

Unknown Object (User) closed this task as Resolved.Dec 8 2021, 02:39
Unknown Object (User) claimed this task.

All The Tropes is also receiving a similar error on any attempt to edit or create a page:

[fce5dff298319b556427e025] 2021-12-07 20:02:19: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

that should be fixed

Not yet:

[f8bc0aa6792e4fabda755313] 2021-12-08 02:45:22: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

Unknown Object (User) added a comment.EditedDec 8 2021, 02:47

All The Tropes is also receiving a similar error on any attempt to edit or create a page:

[fce5dff298319b556427e025] 2021-12-07 20:02:19: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

that should be fixed

Not yet:

[f8bc0aa6792e4fabda755313] 2021-12-08 02:45:22: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

Hmm, interesting. I thought I fixed it. I'll look further tomorrow then I'm off for the night already. But @Reception123 or @RhinosF1 might be able to sooner take a look. Apologies.

This should finally be resolved now. Apologies for the inconvenience.

Sorry, but I'm afraid it is not solved.

[82cd0c54018b8b6102e88fc0] 2021-12-08 09:17:51: Excepció fatal del tipus «Wikimedia\Rdbms\DBQueryError»

Less important: Extension:Maps stopped working after upgrading miraheze to 1.37.0. For example, https://theresnothingbetter.miraheze.org/wiki/Places (private wiki) does not show the map of places at the top of the page.

Less important: Extension:Maps stopped working after upgrading miraheze to 1.37.0. For example, https://theresnothingbetter.miraheze.org/wiki/Places (private wiki) does not show the map of places at the top of the page.

We had to disable Maps unfortunately due to a compatibility issue. We hope to reenable it soon though.

Reception123 lowered the priority of this task from Unbreak Now! to High.Dec 9 2021, 07:51

Issues are not wiki-wide but limited to Cargo now so moving to High

Although upgraded locally for Miraheze, Preloader still won't allow templates to be created:

[4656776a768dab29226f7c0a] 2021-12-09 14:25:19: Fatal exception of type "ArgumentCountError"

Unknown Object (User) added a comment.Dec 9 2021, 14:41

Although upgraded locally for Miraheze, Preloader still won't allow templates to be created:

[4656776a768dab29226f7c0a] 2021-12-09 14:25:19: Fatal exception of type "ArgumentCountError"

Fixed with https://github.com/Universal-Omega/Preloader/commit/e0d0343c005f90c8936450eebea8fe0b89a1c5a2 — Preloader just needs updated again now.

Unknown Object (User) added a comment.Dec 10 2021, 22:26

The issue with Cargo is caused by https://github.com/wikimedia/mediawiki-extensions-Cargo/commit/b68e912, which uses the wrong SQL. I was able to build some correct SQL which does properly return:

New/Correct
SELECT `anotacions_zk`.`_pageID` AS `cargo_backlink_page_id_anotacions_zk`,`anotacions_zk__tags`.`_value` AS `_value`  FROM `cargo__anotacions_zk__tags` AS `anotacions_zk__tags`, `cargo__anotacions_zk` AS `anotacions_zk` GROUP BY `_value` ORDER BY `_value` LIMIT 100;|
Current/Incorrect
SELECT  `anotacions_zk`.`_pageID` AS `cargo_backlink_page_id_anotacions_zk`,`_value` AS `_value`  FROM `cargo__anotacions_zk__tags`  GROUP BY `_value` ORDER BY `_value` LIMIT 100

This will likely need reported upstream.

Unknown Object (User) closed this task as Resolved.Dec 10 2021, 22:38
Unknown Object (User) added a project: Upstream.

Closing as resolved since the only remaining issue here is now Upstream and all other issues have been resolved.