Page MenuHomeMiraheze

Multiple pages broken in multiple ways
Closed, ResolvedPublic

Description

I am aware that the front page of my wiki most likely is broken due to a known bug, however I don't know for the other pages; I am unable to access practically any pages, especially with templates, on my main wiki, available here: https://spektro.miraheze.org, such as all character pages being inaccessible due to error like "[49e5ca599b7838d07073c7be] 2021-10-31 12:53:43: Fatal exception of type "Error""

The main page is broken because of "[7ff3fdb0935763696f16741b] 2021-10-31 12:53:59: Fatal exception of type "Error""

Then, my templates are very bizzarly stretched, like on this page https://spektro.miraheze.org/wiki/Template:Infobox_language

Finally, all my template boxes say something like "<templatestyles src="Module:Navbar/styles.css"></templatestyles>" visibly on them, but I feel that should be hidden information as its above the title and in a different format and size. Examples on this page: https://spektro.miraheze.org/w/index.php?search=Vehicles&title=Special%3ASearch&go=Go

Event Timeline

Herald added subscribers: Unknown Object (User), Unknown Object (User), RhinosF1, Void. · View Herald TranscriptOct 31 2021, 15:55
Unknown Object (User) added a comment.Nov 6 2021, 22:53

This is the same issue as T8184, however because the wiki is private we will not have any backup of the wiki on our side, and none exists from DataDump on the wiki, and therefore I do not believe this is possible to fix.

Unknown Object (User) added a comment.Nov 6 2021, 23:00

as for the templatestyles issue, it is because you don't have TemplateStyles enabled in https://spektro.miraheze.org/wiki/Special:ManageWiki/extensions#mw-section-parserhooks

Unknown Object (User) added a comment.Nov 7 2021, 17:43

We can probably retrieve most recent revisions of articles and fix those but past revisions would still be broken. Recent revisions can be retrieved by trying to edit the page, the text would properly appear. You could then copy that text, delete the page, and re-create it, re-adding the text probably is the best/only way to really fix that.

I have saved my pages. Is it possible to just wipe my wiki and refresh it that way? As long as I can copy my things out I don't mind losing the wiki's progress since I could quickly bring it back to date.

For my templatestyles problem, it now says "Page Module:Navbar/styles.css must have content model "Sanitized CSS" for TemplateStyles (current model is "CSS")."; "Page Module:Hatnote/styles.css must have content model "Sanitized CSS" for TemplateStyles (current model is "CSS")." et cetera. Would this be solved using PortableInfoboxes such as available here: https://www.mediawiki.org/wiki/Extension:PortableInfobox ?

Unknown Object (User) added a comment.Nov 7 2021, 17:48
In T8232#166747, @SPK wrote:

I have saved my pages. Is it possible to just wipe my wiki and refresh it that way? As long as I can copy my things out I don't mind losing the wiki's progress since I could quickly bring it back to date.

For my templatestyles problem, it now says "Page Module:Navbar/styles.css must have content model "Sanitized CSS" for TemplateStyles (current model is "CSS")."; "Page Module:Hatnote/styles.css must have content model "Sanitized CSS" for TemplateStyles (current model is "CSS")." et cetera. Would this be solved using PortableInfoboxes such as available here: https://www.mediawiki.org/wiki/Extension:PortableInfobox ?

For that you would have to go to Special:ChangeContentModel to change it to Santized CSS. As for resetting the wiki, yes we can reset it, but we'd be unable to restore any backup on our end, as any backup we generated now would result in the same issue, so you'd have to restore it yourself through copying recent revisions out of your wiki and pasting them back in later. Is that something you'd be OK with doing?

Unknown Object (User) added a project: Database.Nov 7 2021, 18:21
Unknown Object (User) moved this task from Backlog to Maintenance Script Run on the MediaWiki board.
Unknown Object (User) moved this task from Backlog to Short Term on the Technology-Team (MediaWiki) board.
Unknown Object (User) closed this task as Declined.Nov 9 2021, 18:16
Unknown Object (User) claimed this task.

Hello, please reopen this task when you let us know how you wish to proceed. Thanks!

I apologise for the issues caused by this.

By copying recent revisions do you mean the text or something like html documents? I've copied all the written information on my wiki through edit > select all > copy to local disk drive. In that case I'm ready to proceed with the wipe, but if you mean another thing do let me know thanks

Unknown Object (User) reopened this task as Open.Nov 9 2021, 18:22
In T8232#166910, @SPK wrote:

By copying recent revisions do you mean the text or something like html documents? I've copied all the written information on my wiki through edit > select all > copy to local disk drive. In that case I'm ready to proceed with the wipe, but if you mean another thing do let me know thanks

Yes I meant copying text, you will have to manually paste that in after the wipe. For reasons of copyright however, are you the only contributor on the wiki? In which case just the recent revision, which is all that seems recoverable is fine, otherwise we will have to figure something else out.

Unknown Object (User) removed Unknown Object (User) as the assignee of this task.Nov 9 2021, 18:23

Yes I am the only contributor

Unknown Object (User) added a comment.Nov 9 2021, 18:27
In T8232#166914, @SPK wrote:

Yes I am the only contributor

OK then, just for final clarification you or OK with a complete database wipe, which will wipe every page, revision, ManageWiki configuration, etc... from your wiki? If you wish to backup your ManageWiki settings and images, which I do recommend, you should be able to do so from Special:DataDump.

Unknown Object (User) moved this task from Unsorted to Short Term on the Universal Omega board.Nov 9 2021, 18:27

Yep, I'm all ready and I used the tool to save additional copies

Reception123 claimed this task.

Sorry for how long this took, this is now done and your wiki has been fully reset.

No worries, thankfully i backed it up multiple ways so now I need to open a task for an xml import