Page MenuHomeMiraheze

Test all extensions for 1.37
Closed, ResolvedPublic

Description

Update this task with a list of fully tested extensions, as they are tested. Note which issues they have and whether they should be removed, are an upgrade blocker, or any other relevant details.

Only extensions or skins that seem to fully work without issue, or when the issue is acceptable to move forward with MediaWiki 1.37 deployment, should be checked off this list. Please also note blockers on the Production Blockers list of the parent task.

Extensions:
  • 3D
  • AbuseFilter
  • AddHTMLMetaAndTitle
  • AddThis
  • AdminLinks
  • AJAXPoll
  • AntiSpoof
  • ApprovedRevs
  • Arrays
  • ArticleCreationWorkflow
  • ArticlePlaceholder
  • ArticleRatings
  • ArticleToCategory2
  • AuthorProtect
  • AutoCreateCategoryPages
  • AutoCreatePage
  • Babel
  • BetaFeatures
  • BlogPage
  • Calendar-Wikivoyage
  • Capiunto
  • Cargo
  • CategorySortHeaders
  • CategoryTree
  • CentralAuth
  • CentralNotice
  • CharInsert
  • CheckUser [Done by RhinosF1]
  • Cite
  • CiteThisPage
  • cldr
  • CleanChanges
  • CodeEditor
  • CodeMirror
  • CollapsibleVector
  • Commentbox
  • Comments
  • CommentStreams
  • CommonsMetadata
  • ConfirmEdit
  • ContactPage
  • ContributionScores
  • CookieWarning
  • CountDownClock
  • CreatePage
  • CreatePageUw
  • CreateRedirect
  • CreateWiki
  • CSS
  • DarkMode
  • DataDump
  • DataTransfer
  • DeleteUserPages
  • Description2
  • Disambiguator
  • DiscordNotifications
  • DiscussionTools
  • DismissableSiteNotice
  • DisplayTitle
  • DPLForum
  • DummyFandoomMainpageTags
  • DynamicPageList
  • DynamicPageList3
  • DynamicSidebar
  • Echo
  • Editcount
  • EditNotify
  • EditSubpages
  • EmbedSpotify
  • EmbedVideo
  • EventLogging (only required by CentralNotice, since that works, this works)
  • EventStreamConfig (only required by EventLogging, therefore CentralNotice, since that works, this works)
  • FancyBoxThumbs
  • FlaggedRevs
  • Flow
  • FontAwesome
  • ForcePreview
  • Gadgets
  • Genealogy
  • GeoCrumbs
  • GeoData
  • GeoGebra
  • GettingStarted
  • GlobalBlocking
  • GlobalCssJs
  • GlobalNewFiles
  • GlobalPreferences
  • GlobalUsage
  • GlobalUserPage
  • GlobalWatchlist
  • GoogleDocs4MW
  • GoogleNewsSitemap
  • Graph
  • GroupsSidebar
  • GuidedTour
  • HAWelcome
  • HeaderFooter
  • HeaderTabs
  • HideSection
  • HighlightLinksInCategory
  • ImageMap
  • ImageRating
  • IncidentReporting
  • InputBox
  • Interwiki
  • JavascriptSlideshow
  • Josa
  • JSBreadCrumbs
  • JsCalendar
  • JsonConfig
  • Kartographer
  • LabeledSectionTransclusion
  • LanguageSelector
  • LastModified
  • LdapAuthentication
  • Lingo
  • LinkSuggest
  • LinkTarget
  • LinkTitles
  • Linter
  • Listings
  • LocalisationUpdate
  • LockAuthor
  • LoginNotify
  • LogoFunctions
  • Loops
  • MagicNoCache
  • MagicNumberedHeadings
  • ManageWiki
  • Maps
  • MassEditRegex
  • MassMessage
  • Math
  • MatomoAnalytics
  • MediaWikiChat
  • Mermaid
  • MintyDocs
  • MirahezeMagic
  • MixedNamespaceSearchSuggestions
  • MobileDetect
  • MobileFrontend
  • MobileTabsPlugin
  • Moderation
  • MsCalendar
  • MsCatSelect
  • MsLinks
  • MsUpload
  • MultiBoilerplate
  • MultimediaViewer
  • MyVariables
  • NewestPages
  • NewSignupPage
  • Newsletter - Conflicts with Lingo. [0ab315500e448892de177e6e] 2021-11-27 06:17:44: Fatal exception of type "Error"
  • NewUserMessage
  • NewUserNotif
  • NoTitle
  • Nuke
  • NukeDPL
  • NumberedHeadings — works, but...
  • OATHAuth
  • OAuth
  • OpenGraphMeta
  • OrphanedTalkPages
  • PageAssessments
  • PagedTiffHandler
  • PageForms
  • PageImages
  • PageNotice
  • PageSchemas
  • PageTriage
  • ParserFunctions
  • PdfBook - failed to load
  • PDFEmbed
  • PdfHandler
  • PipeEscape
  • Poem
  • PollNY
  • Popups
  • PortableInfobox
  • Preloader
  • ProofreadPage
  • ProtectionIndicator
  • ProtectSite
  • Purge
  • Quiz
  • QuizGame
  • RandomGameUnit
  • RandomImage
  • RandomSelection
  • RatePage
  • RegexFunctions
  • RelatedArticles
  • RemovePII
  • Renameuser
  • ReplaceText
  • Report
  • RevisionSlider
  • RightFunctions
  • RottenLinks
  • RSS
  • SandboxLink
  • ScratchBlocks4
  • Scribunto
  • SecureLinkFixer
  • ShortDescription
  • SimpleBlogPage
  • SimpleChanges
  • SimpleTooltip
  • SkinPerPage
  • SlackNotifications
  • SnapProjectEmbed
  • SocialProfile
  • SoftRedirector
  • SpamBlacklist
  • Spoilers
  • SpriteSheet
  • StopForumSpam
  • SubpageFun
  • SubPageList3
  • SyntaxHighlight_GeSHi
  • Tabber
  • TabberNeue
  • Tabs
  • TemplateData
  • TemplateSandbox
  • TemplateStyles
  • TemplateStylesExtender
  • TemplateWizard
  • TextExtracts
  • Thanks
  • Theme
  • TimedMediaHandler
  • Timeline
  • TimeMachine
  • TitleBlacklist
  • TitleKey
  • TocTree
  • TorBlock
  • Translate
  • TranslationNotifications
  • TreeAndMenu
  • TwitterTag
  • TwoColConflict
  • UniversalLanguageSelector
  • UploadsLink
  • UrlGetParameters
  • UrlShortener
  • UserFunctions
  • UserMerge
  • UserPageEditProtection
  • Variables
  • VariablesLua
  • VEForAll
  • Video
  • VisualEditor
  • VoteNY
  • WebChat
  • Wikibase
  • WikibaseLexeme
  • WikibaseLocalMedia
  • WikibaseQualityConstraints
  • WikiCategoryTagCloud
  • WikidataPageBanner
  • WikiDiscover
  • WikiEditor
  • WikiForum
  • wikihiero
  • WikiLove
  • WikimediaIncubator
  • WikiSEO
  • WikiTextLoggedInOut
  • YouTube
Skins:
  • Anisa
  • apex
  • BlueSky
  • chameleon
  • Citizen
  • CologneBlue
  • Cosmos
  • DuskToDawn
  • erudite
    • PHP Warning: Invalid argument supplied for foreach() from /srv/mediawiki/w/skins/erudite/Erudite.skin.php(230)
  • Evelution
    • Deprecated: Template directory should be relative to skin or omitted. [Called from ExtensionProcessor::extractInfo in /srv/mediawiki/w/includes/registration/ExtensionProcessor.php at line 197] (https://github.com/AWikia/SkinEvelution/pull/85)
  • Femiwiki
  • Flatbox
    • Deprecated: Template directory should be relative to skin or omitted. [Called from ExtensionProcessor::extractInfo in /srv/mediawiki/w/includes/registration/ExtensionProcessor.php at line 197]
  • foreground
  • Gamepress
  • HasSomeColours
  • liberty
  • Mask
  • Medik
  • Metrolook
  • MinervaNeue
  • Mirage
    • Argument 3 passed to MediaWiki\Skins\Mirage\RightRailModules\GenericItemListModule::__construct() must be of the type array, string given, called in /srv/mediawiki/w/vendor/wikimedia/object-factory/src/ObjectFactory/ObjectFactory.php on line 244 - https://phabricator.wikimedia.org/T296809 - conflicts with AddThis.
  • Modern
  • Monaco
  • MonoBook
  • Nimbus
  • Nostalgia
  • pivot
  • Refreshed
  • snapwikiskin
    • Deprecated: Template directory should be relative to skin or omitted. [Called from ExtensionProcessor::extractInfo in /srv/mediawiki/w/includes/registration/ExtensionProcessor.php at line 197]
  • Timeless
  • Truglass
  • Tweeki
    • PHP Notice: Undefined index: edit from /srv/mediawiki/w/skins/Tweeki/includes/TweekiTemplate.php(70)
  • Vector
  • WMAU
    • Deprecated: Template directory should be relative to skin or omitted. [Called from ExtensionProcessor::extractInfo in /srv/mediawiki/w/includes/registration/ExtensionProcessor.php at line 197]

303/306 OK - UPDATED 02/12 23:25 UTC

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Lakelimbo subscribed.

CodeEditor and CodeMirror working normally.

In T8166#167725, @Ugochimobi wrote:

Can I update the task when I find out an extension works properly? @Reception123

Yes

Translate needs to be switched to REL1_37 because a recent update broke VisualEditor because it depends on a change only in master VisualEditor.

This should be fixed in master and was a breach of compatibility rules for translate.

In T8166#167725, @Ugochimobi wrote:

Can I update the task when I find out an extension works properly? @Reception123

Yes

Thank you, lol, I already did though.

Unknown Object (User) updated the task description. (Show Details)Nov 19 2021, 17:37
Unknown Object (User) updated the task description. (Show Details)Nov 19 2021, 18:30
Unknown Object (User) updated the task description. (Show Details)Nov 19 2021, 18:40

VE should just need bumping to latest master

Skin:Liberty works fine it’s just that it’s incompatible with VisualEditor. I believe if you disable VE it would work without issues. The wiki that the skin is developed for runs LTS versions of MediaWiki and thus compatibility with the latest MW stable is low priority for the devs.

Unknown Object (User) updated the task description. (Show Details)Nov 20 2021, 00:39
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Nov 20 2021, 00:44
Unknown Object (User) updated the task description. (Show Details)Nov 20 2021, 00:51

FontAwesome working normally. I tried to use FancyBoxThumbs but it did not work, however I don't see any errors on the console.

Unknown Object (User) added a comment.Nov 20 2021, 16:48

FontAwesome working normally. I tried to use FancyBoxThumbs but it did not work, however I don't see any errors on the console.

FancyBoxThumbs is one I maintain so I will investigate that one. Thanks!

Unknown Object (User) updated the task description. (Show Details)Nov 20 2021, 22:58
Unknown Object (User) updated the task description. (Show Details)Nov 20 2021, 23:02
Unknown Object (User) added a comment.EditedNov 20 2021, 23:49

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikiForum/+/740253 should fix the WikiForum issue, which the patch is now live on test3.

Unknown Object (User) updated the task description. (Show Details)Nov 21 2021, 18:43
Unknown Object (User) added a comment.Nov 22 2021, 18:53

My WikiForum patch has been merged upstream so that issue should now be fixed.

Unknown Object (User) updated the task description. (Show Details)Nov 22 2021, 18:53
Unknown Object (User) added a comment.Nov 22 2021, 19:21

I mentioned this on the upstream task for this, but I assume the issue with DarkMode is that anontalk does not exist if * does not have the edit permission.

Skin:Liberty works fine it’s just that it’s incompatible with VisualEditor. I believe if you disable VE it would work without issues. The wiki that the skin is developed for runs LTS versions of MediaWiki and thus compatibility with the latest MW stable is low priority for the devs.

After more testing, removing VE doesn't fix the skin. As I said, compatibility with latest stable is low priority for the devs.

Unknown Object (User) added a comment.Nov 22 2021, 21:10

Maps is incompatible with PHP 7.3, only PHP 7.4+, and the version that is compatible with PHP 7.3 is incompatible with MediaWiki 1.37.

Unknown Object (User) updated the task description. (Show Details)Nov 22 2021, 22:43
Unknown Object (User) updated the task description. (Show Details)Nov 22 2021, 22:48
Unknown Object (User) updated the task description. (Show Details)Nov 22 2021, 23:50
Unknown Object (User) updated the task description. (Show Details)Nov 23 2021, 00:03
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Nov 23 2021, 00:05
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Nov 23 2021, 00:18
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Nov 23 2021, 02:13
Unknown Object (User) updated the task description. (Show Details)Nov 23 2021, 02:16
RhinosF1 raised the priority of this task from Normal to High.Nov 23 2021, 13:33

Blocker of a high priority task so should be high by definition

Unknown Object (User) updated the task description. (Show Details)Nov 23 2021, 19:25
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 17:33
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 17:55
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 18:05
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 18:21
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 18:33
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 18:43
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 18:46
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 21:03
Unknown Object (User) updated the task description. (Show Details)Nov 24 2021, 21:26
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 18:52
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 19:22
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 19:30
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 19:45
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 20:05
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 20:09
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 20:12
Unknown Object (User) updated the task description. (Show Details)Dec 1 2021, 22:58

Cargo working normally now. The only things I couldn't test are complex API calls (using cargoquery) and queries via Lua (because I don't know Scribunto), however considering that everything else I tested is working normally, I don't think there's any issues.

Unknown Object (User) updated the task description. (Show Details)Dec 2 2021, 19:45
Unknown Object (User) updated the task description. (Show Details)Dec 2 2021, 19:52
Unknown Object (User) updated the task description. (Show Details)Dec 2 2021, 19:54
Unknown Object (User) updated the task description. (Show Details)Dec 2 2021, 20:36
Unknown Object (User) updated the task description. (Show Details)Dec 2 2021, 20:41
Unknown Object (User) updated the task description. (Show Details)Dec 2 2021, 21:01
Unknown Object (User) updated the task description. (Show Details)Dec 2 2021, 23:24
Unknown Object (User) updated the task description. (Show Details)
Unknown Object (User) closed this task as Resolved.Dec 2 2021, 23:37
Unknown Object (User) claimed this task.
  • PdfBook is mostly unmaintained, and not on Wikimedia Gerrit, so I don't see any fix happening there. We should consider removal.
  • EmbedVideo and WikibaseLocalMedia have upstream tracking. I opened a pull request for WikibaseLocalMedia as well.
  • Liberty will be removed, and has it's own task for that.

Since those are all that remain I am going to go ahead and close this task as resolved, since all remaining issues mentioned are either tracked upstream, or likely will never be fixed and removal should be considered. Any remaining blockers can be tracked in the parent task and this task is no longer necessary to remain open.

Unknown Object (User) updated the task description. (Show Details)Dec 3 2021, 01:15
Unknown Object (User) updated the task description. (Show Details)