Page MenuHomeMiraheze

Cannot edit own Social Profile
Closed, ResolvedPublic

Description

https://allthetropes.org/wiki/User_profile:SelfCloak

I am an admin at AllTheTropes and wanted to edit outdated info on my Social Profile, but it won't let me.

"Sorry, you cannot create a user profile until you have at least 10 edits" I have a user profile??? and I have well over 20K edits...

Event Timeline

I can't see anything obvious as to why it fails. You definately have more than 10 edits.

Unknown Object (User) moved this task from Backlog to Short Term on the Technology-Team (MediaWiki) board.Mar 21 2021, 19:50
Unknown Object (User) moved this task from Unsorted to Short Term on the Universal Omega board.
Unknown Object (User) added a comment.EditedMar 22 2021, 15:31

I've messaged the developer on IRC:

9:11 AM <Universal_Omega> Hi, sorry to bother you again, but would you happen to know why https://phabricator.miraheze.org/T7013 would happen?
9:21 AM
<ashley> so the error is happening because $wgUserProfileThresholds['edits'] is set (and of course it oughta be set for a public, high-traffic site because spambots, sadly); however the question of "*why* does MW/SP think the user does not have enough edits?" is a more curious one...if you have DB access or know someone who has, see about the value of stats_edit_count column for that user (identified via their actor ID) in the user_stats table; if the counts in general are out of sync for whatever reason (shouldn't really happen but this *is* MW we're talking about...) you may wish to refresh them via [[Special:UpdateEditCounts]] (though I wouldn't be surprised if that special page timed out on a high-traffic wiki w/ lots of edit history...frankly there should be a maintenance script version of that but there...isn't currently)
9:36 AM
<ashley> that seems like the most probable cause, although if $wgEmailConfirmToEdit is set to true and the user does *not* have a confirmed email, it should disallow editing the profile (_and_ also show a meaningful, /different/ error message specifically stating that email confirmation is required to be able to edit the profile); mind you, this does bring up an interesting point/feature request: there probably should be a user right override for that, so that someone can be an admin, edit their profile and not (yet) have the required # of edits, for example

stats_edit_count seems to be returning a value of 0.

@SelfCloak Could you try Special:UpdateEditCounts and see if it works and doesn't time out?

@SelfCloak Could you try Special:UpdateEditCounts and see if it works and doesn't time out?

@Reception123 the Special:UpdateEditCounts special page seems to require the updatepoints user right; however, by default, no group has this user right. I tried viewing the unassigned permissions for the sysop group on the wiki, but that user right wasn't even made available in ManageWiki by default. So, even if we wanted to ask a bureaucrat to add that user right, they wouldn't be able to add it. So is there a further configuration change needed globally to add additional SocialProfile user rights to ManageWiki?

Unknown Object (User) added a comment.Mar 22 2021, 22:26

@SelfCloak Could you try Special:UpdateEditCounts and see if it works and doesn't time out?

@Reception123 the Special:UpdateEditCounts special page seems to require the updatepoints user right; however, by default, no group has this user right. I tried viewing the unassigned permissions for the sysop group on the wiki, but that user right wasn't even made available in ManageWiki by default. So, even if we wanted to ask a bureaucrat to add that user right, they wouldn't be able to add it. So is there a further configuration change needed globally to add additional SocialProfile user rights to ManageWiki?

That right was intentionally restricted I believe.

Unknown Object (User) added a comment.Mar 22 2021, 23:08

Hello, I've updated editcounts, can you please see if it works now?

Unknown Object (User) closed this task as Resolved.Mar 22 2021, 23:29
Unknown Object (User) claimed this task.

Yes it works now, thank you.

Glad it's resolved. And no problem!