Page MenuHomeMiraheze

Cannot log back in after cookies update
Closed, ResolvedPublic

Description

My Miraheze account Ertosi is unable to log back in to Miraheze wikis since the cookies update on either Microsoft Edge or Internet Explorer (the two browsers I use the most). Despite using the correct user name and passcode, each time I try to log in I receive the following message "There seems to be a problem with your login session; this action has been canceled as a precaution against session hijacking. Please resubmit the form."

I know that I am using the correct user name and passcode as I was able to log in with them just now using an old version of Google Chrome (which looks awful). I need to be able to log in using Edge (as that is the browser in which the site looks and functions best) and Internet Explorer (as that is the only browser that seems to be able to upload lots of images without occasionally freezing).

Here are the things I've already tried, which did not fix the issue:

  • Turned it off and on.
  • Deleted all cookies.
  • Opened private browsing mode and used Special:UserLogout.
  • Deleted all cookies again.
  • Attempted to use the Forgot passcode option.

Any help is appreciated, but as I've already lost over an hour of my morning to this issue when I was hoping for a little relaxing editing before work I'd rather skip the "maybe this will work, try this and that out for a while" potential solutions and skip straight to a working solution. Thanks!

Event Timeline

RhinosF1 triaged this task as High priority.Dec 7 2020, 13:53

I have the same log in failure experience on nenawiki.org using Edge Version 87.0.664.57 (Official build) (64-bit). Usually, I get the error once and I succeed on the second attempt. But today, the error is persistent.

I can log in using:

  • Firefox 83.0 (64-bit)
  • Chrome Version 87.0.4280.88 (Official Build) (64-bit)
In T6558#128885, @MikeV wrote:

I have the same log in failure experience on nenawiki.org using Edge Version 87.0.664.57 (Official build) (64-bit). Usually, I get the error once and I succeed on the second attempt. But today, the error is persistent.

I can log in using:

  • Firefox 83.0 (64-bit)
  • Chrome Version 87.0.4280.88 (Official Build) (64-bit)

Hi. Could you maybe try to follow all the steps again on the Edge browser?

In T6558#128885, @MikeV wrote:

I have the same log in failure experience on nenawiki.org using Edge Version 87.0.664.57 (Official build) (64-bit). Usually, I get the error once and I succeed on the second attempt. But today, the error is persistent.

I can log in using:

  • Firefox 83.0 (64-bit)
  • Chrome Version 87.0.4280.88 (Official Build) (64-bit)

Hi. Could you maybe try to follow all the steps again on the Edge browser?

I cleared the cache and cookies and tried Edge's InPrivate window. Same result.

image.png (262×307 px, 13 KB)

@MikeV Did you go to Special:UserLogout for login.miraheze.org too on the regular browser?

@MikeV Did you go to Special:UserLogout for login.miraheze.org too on the regular browser?

Assuming that "regular browser" means Edge "public" browser. I just tried all that. Then, when I tried to log into our site, I got the same persistent error.

I followed all of the steps again on Edge and I'm now able to log in. The issue is resolved for me. Thanks for the help!

Still unable to log into my account on Internet Explorer. Followed all of the steps provided again and still getting the message that I'm trying to hijack my own account.

I think I previously failed to clear the Edge cache correctly by not selecting "All time" in the Edge settings "Time range" field. After doing that, I can successfully log in to Edge. Thanks.

Unknown Object (User) added a subscriber: Emad4ald.
Unknown Object (User) added a subscriber: Oliver.hurtig.

(whoops, meant to do this the other way)

I could login and edit on edge, but I received this massage (translated from portuguese) "It seems to be a problem with your login session; This action was canceled as a precaution against session hijacking. Please resend the form."
Despite the message, I was able to make the edits

John claimed this task.
John subscribed.

The issue should be resolved by refreshing the page and/or logging in again. More useful debugging information would be;

  • Which wiki the problem occurred on
  • When exactly
  • Which account(s)
  • Whether a session token was set via cookies on either the wiki's url or miraheze.org.

Refreshing page do not resolve
I can´t logout: "invalid CSRF token" - But I dont know whats is this

Which wiki the problem occurred on:
https://pinheirense.miraheze.org/wiki/P%C3%A1gina_principal

When exactly
Everrtime I tried to edit a page

Which account(s)
https://pinheirense.miraheze.org/wiki/Usu%C3%A1rio:Masopias

Whether a session token was set via cookies on either the wiki's url or miraheze.org.
O don't know. I just open the wiki in chrome or edge and try to edit a page, using my account "masopias"