Page MenuHomeMiraheze

Sidebars and vector tabs aren't working properly post-upgrade
Closed, InvalidPublic

Description

(Vector skin) Ever since the upgrade to 1.35, not the sidebars nor the vector tabs at the top of the page react to CSS, and the sidebars become distorted in their collapsible setting.

Related Objects

Event Timeline

Unknown Object (User) triaged this task as Normal priority.Oct 28 2020, 12:17
Unknown Object (User) added a project: Extensions.
Unknown Object (User) moved this task from Backlog to Deployed Extension Bugs on the Extensions board.Oct 28 2020, 12:17
Unknown Object (User) removed Oneiro as the assignee of this task.Oct 28 2020, 15:00
Unknown Object (User) added a comment.Oct 28 2020, 21:46

What wiki would this be?

I first noticed it on my own wiki, but I have seen it on other wikis as well, such as DifferentHistory and AllTheTropes.

Unknown Object (User) added a comment.Oct 30 2020, 14:46

Seems to look wrong to me, but also likely changes to CSS element classes or something. Try to change the vector mode to use "Legacy" in Special: Preferences and see if that works.

I'm afraid that whether or not Legacy Vector is active has no effect on the elements in question.

I think sidebars look distorted is Extension:CollapsibleVector 's bug, and I found a task on https://phabricator.wikimedia.org that describes this issue.

I tried to fix it using CSS:

#mw-panel.collapsible-nav .portal h3 {
  background-size: inherit;
  padding: 4px 0 4px 1.5em;
}

I found the cause of the problem with the vector tabs here.

Unknown Object (User) added a subscriber: Amelia.

Terribly sorry, but has there been any solution so far? I tried putting in the JS code in one of the phabs posted in my Vector.js to no avail.

Terribly sorry, but has there been any solution so far? I tried putting in the JS code in one of the phabs posted in my Vector.js to no avail.

Hello.

I saw your Vector.css, and I found some issues in it:

  • div.vectorTabs should be nav.vectorTabs (or nav.vector-menu-tabs)
  • div.vectorMenu should be nav.vectorMenu (or nav.vector-menu-dropdown)
  • .vectorTabs span should be .vectorTabs a

because in MW 1.35, these elements had been changed or deleted.

I think if these changes applied, your wiki's tabs may be changes a bit.

Thank you so much! It's not all there yet, the 'watch/unwatch' button and 'more' button are still not perfect, but it's better then before!

Unknown Object (User) closed this task as Invalid.Nov 12 2020, 08:15

Closing as this issue is relating to css class changes, nothing that we can do but each individual wiki will have to.