Page MenuHomeMiraheze

VisualEditor Issues
Closed, ResolvedPublic


Error loading data from server: apierror-visualeditor-docserver-http: HTTP 0. Would you like to try again?

I am getting this error (quite often) on my private wiki. I don't remember this being a prevalent issue but it has led to me losing significant contributions to my pages and it's very demotivating to have to right it again :/ Any advise or expertise on how this matter could be resolved or what's the cause of the issue?

Event Timeline

CnocBride triaged this task as Normal priority.Nov 15 2019, 22:27
CnocBride created this task.

@Paladox @Reception123 Hi! Haven't been on Miraheze in the last few days, very busy, but is there any progress on what the source of this issue would be? No rush, eitherway.

Did you clear the cache? @CnocBride

No, but I read somewhere that it was also on other wikis and I seen some comment by Paladox on Phabricator too with a possible hypothesis for why its occurring – doubt it is a caching issue.

Examknow raised the priority of this task from Normal to High.Nov 22 2019, 19:42

@Pfyh had the same issue on his wiki and I have also seen this on metawiki. This really needs to be fixed since we advertise having VisualEditor support and this has been going on for quite a while now.

He is also doubling to see what a horrible thing is happening. Don't need to do an update.php on the server?

exemplo1.png (555×1 px, 257 KB)

I have decided that I think it is more of a problem with the VisualEditor extension itself and not with the Miraheze servers but I cannot be sure unless I was to get in there and look at it myself.

I have the same issue with the visual editor. The error(s) appear in such a frequency that working with the visual editor has become uneasy and annoying. I get three types of error messages.

Foutmelding-1.jpg (204×359 px, 33 KB)

Foutmelding-2.jpg (179×319 px, 28 KB)

Foutmelding-3 bij opslaan.jpg (405×493 px, 65 KB)

Error 1 says it could not get data from the server, because it could not connect to the server.
Error 2 suggests it has to do with an API and HTTP 0
Error 3 says HTTP 0

There is less problem working in the Wiki text mode.

Normally I edit in Google Chrome in a Windows 10 OS. But when I tried to work in MS Edge, the same issue occurred.

My reaction to the errors with regard to editing and saving the text is twofold: (1) keep trying to get the text or to save the text until it succeeds, or (2) switch to the wiki text mode and edit and save from there.

Any news? Still not able to edit on my private wiki...

Paladox claimed this task.

Fixed with

Please reopen/file a new task if it still happens.

I just tried re-enabling the VisualEditor on my wiki and immediately got this error when I tried to use it:

Error loading data from server: apierror-visualeditor-docserver-http: HTTP 404. Would you like to retry?

Should I expect it to take some amount of time before it's working?

Yup, should take 10-20 minutes after enabling to work.

For me the error still occurs but I have to wait a long time a few times. But it depends on the time and it also depends on the following: After working well for a while, it starts to give the same error. I even use purge and purge cache. But the good thing is to always save because if you spend a long time without saving it gives the error and does not save at all.