Page MenuHomeMiraheze

Upgrade to MediaWiki 1.32
Closed, ResolvedPublic

Description

As usual it's that time of year when there's a MediaWiki upgrade. We should upgrade because it may fix performance problems with ATT main page (not 100% sure but results look promising).

Also issues with actor are fixed with PageTriage which is causing some wikis to fatal (if they go to that specific api)

Event Timeline

We should upgrade because we commit to the latest version.

Reasons are irrelevant.

In T3794#72741, @John wrote:

We should upgrade because we commit to the latest version.

Reasons are irrelevant.

This.

But also didn't the 1.32 rc.0 just come out?

AmandaCath subscribed.

Hmm... am I missing something here? I haven’t seen anything on the mw mailing list about a new version release, and the version lifecycle on MediaWiki.org still displays 1.31 as the latest version. To make things even stranger the lifecycle timeline jumps from 1.31 to 1.33 (skipping 1.32 altogether). Anyone have any insight?

1.32 is in RC stages, so it's not a formal release yet but it's no longer in alpha (which is 1.33).

Reception123 triaged this task as Normal priority.Nov 16 2018, 16:38

Normal priority until its out.

Just leaving a FYI, this is a high priority once released. Seeing as initial tests show performance improvements (re att slow main page loading).

Just leaving a FYI, this is a high priority once released.

They’re always high priority when released

Housekeeping note, appears that this will be done very soon per 7f8ee98cf628

MacFan4000 closed this task as Resolved.EditedJan 11 2019, 13:01

A wiki erroring doesn’t mean that the upgrade hasn’t been done. It’s just an issue caused by this being done.