Page MenuHomeMiraheze

Comments from Visual Editor not displaying properly
Closed, InvalidPublic

Description

List of steps to reproduce (step by step, including full links if applicable):

What happens?:
When placing comments using the Visual Editor "Comment" function that generates comments using <!-- Test Comment 1 --> notation, the comments are input and the code is saved, but they do not display at all. I have tried this in multiple browsers (Firefox + Edge) with and without extensions in case it was a display error and even cleared cookies in case, but nothing has changed it.

I believe this began after I had attempted an experiment importing the Comments extension to test a different commenting system on a page with the existing comments from the visual editor. I did not think there would be any conflict, but since doing, deleting the extension and associated code on my page, nothing has functioned correction since then. Even on other unrelated pages. Restoring old versions of the page did nothing as well.

What should have happened instead?:
Comments should display as intended.

Browser information, screenshots and other applicable information:

Chrome + Firefox with and without extensions, cleared cache+cookies, etc.

Screenshots:
https://www.dropbox.com/scl/fi/feefoph6bfe8x8z7p2ofq/GSError1.png?rlkey=zngec8m2um71xtxpmre4ifmtf&dl=0
https://www.dropbox.com/scl/fi/l0xy74irrmqx0nteh4q3c/GSError2.png?rlkey=2kffpwn329kk0qj8a76a90msb&dl=0

Event Timeline

This issue is still present post-system wwide update

Unknown Object (User) closed this task as Invalid.Dec 28 2023, 11:45

VisualEditor Comments refers to HTML comments which are invisible, hidden comments in the code, meant to be read by editors or developers. I think what you're looking for might be be citations?