Page MenuHomeMiraheze

Favicon not appearing in search results for obeymewiki ...or for any miraheze wiki?
Closed, ResolvedPublic

Description

As the wiki URL for obeymewiki changed to remove the "www." I noticed that pages with the new URL showing up so far in Google searches or DuckDuckGo searches do not have the correct favicon. It was working before, and the favicon at this location: "https://static.miraheze.org/obeymewiki/6/64/Favicon.ico" is still being pointed to in "Special:ManageWiki/settings" Instead, a generic favicon of a globe appears.

This might be a bigger issue than just my wiki though? Because that same globe favicon is also what I see when I search for the Miraheze wiki, and not the yellow flower shape. I also tried searching for other wikis hosted by Miraheze, and they too have that same placeholder favicon.

It is only sites associated with Miraheze that this is happening to. All other search results have their proper favicon appearing.

Event Timeline

I don't see this at other wikis, like Meta and AVID, or yours. At yours I see a favicon of like a bird in a purple background (I think).

OrangeStar triaged this task as Normal priority.Mar 23 2023, 10:52
OrangeStar added a project: MediaWiki (SRE).

Everything looks okay on the wikis, could be just search engines doing their thing.

Everything looks okay on the wikis, could be just search engines doing their thing.

I would have thought that if it was only one search engine this was happening to or if it were sites outside Miraheze being effected as well, but that it's happening on multiple search engines and specifically just on Miraheze hosted wikis seems concerning.

I just searched on DuckDuckGo, and the AVID favicon appears normally, however, searching "miraheze obeyme", which returns your wiki as the third result (first two are the .miraheze.org subdomain) are less consistent, with the link directly to obeymewiki.com (which redirects to the main page) returning no favicons, and www.obeymewiki.com/wiki/Main, which appears just below, do have the favicon.

I really think this is just a problem on their end, and there's really nothing we can do other than wait for search engines to update their databases.

Looks like this is solved (at least on DDG), no action was required.

Unknown Object (User) subscribed.Apr 6 2023, 02:44

This happens on everything using the default favicon also, including Miraheze landing and Miraheze Meta. This is likely caused by Miraheze using 16x16px favicons by default, and your wiki might also, for Google at least, it states:

Your favicon should be a multiple of 48px square, for example: 48x48px, 96x96px, 144x144px and so on. SVG files, of course, do not have a specific size. Any valid favicon format is supported. Google will rescale your image to 16x16px for use in search results, so make sure that it looks good at that resolution. Note: do not provide a 16x16px favicon.

If that isn't the issue, then I'm not sure, but this is a common issue on Miraheze.

This happens on everything using the default favicon also, including Miraheze landing and Miraheze Meta. This is likely caused by Miraheze using 16x16px favicons by default, and your wiki might also, for Google at least, it states:

Your favicon should be a multiple of 48px square, for example: 48x48px, 96x96px, 144x144px and so on. SVG files, of course, do not have a specific size. Any valid favicon format is supported. Google will rescale your image to 16x16px for use in search results, so make sure that it looks good at that resolution. Note: do not provide a 16x16px favicon.

If that isn't the issue, then I'm not sure, but this is a common issue on Miraheze.

Thank you so much for the info! It was very confusing to see not just my wiki, but also other Miraheze-related sites all having the same issue on multiple search engines (which is something that is still happening unfortunately).

My wiki's favicon has now been changed to 48x48px, so hopefully that will solve the issue in that case.